HomeHome  PortalPortal  GalleryGallery  SearchSearch  RegisterRegister  Log in  

Share
 

 TBI rough idle and running 350.

Go down 
AuthorMessage
cllong

cllong

Posts : 6
Join date : 2014-11-07

TBI rough idle and running 350. Empty
PostSubject: TBI rough idle and running 350.   TBI rough idle and running 350. Icon_minitimeMon Nov 10, 2014 7:54 pm

Hi folks. I'm new to the forum and have seen several posts on this topic. My problem is driving me nuts. I have a 1993 Roadmaster wagon that has a 350 TBI. The guy I purchased it from had installed a crate engine. I purchased the wagon about a year ago and for several months it ran fine. Now it won't idle when warm and hesitates and sometimes dies. Even going down the road at a steady speed it misses.Here's a list of what two very fine mechanics have done so far.

New Cat converter
O2
IAC
coil
vacuum hoses
plugs and wires
alternator
Intake manifold gasket

These have not solved the problem. It seemed to run better when the alt was unhooked but a new alt didn't fix it.
Fuel pressure is good. I really love the car other than this. Can a GM 350 really be this complicated? Any suggestions will be greatly appreciated. Stumped in Bowling Green Kentucky.
Back to top Go down
scoffman

scoffman

Posts : 553
Join date : 2012-02-21
Age : 42
Location : Lawrenceburg, KY

TBI rough idle and running 350. Empty
PostSubject: Re: TBI rough idle and running 350.   TBI rough idle and running 350. Icon_minitimeWed Nov 12, 2014 11:49 am

use the KISS method.
Check fuel, Air, and Spark. depending on these checks it will lead you down the right path.

it could be a heat soak issue with the dizzy? or a fuel delivery problem, or an EGR valve issue.
Back to top Go down
Dutch Pete

Dutch Pete

Posts : 421
Join date : 2009-12-07
Age : 59
Location : Netherlands

TBI rough idle and running 350. Empty
PostSubject: Re: TBI rough idle and running 350.   TBI rough idle and running 350. Icon_minitimeWed Nov 12, 2014 1:00 pm

First question, does it show any code's? (check engine light)
Pete
Back to top Go down
sswagon

sswagon

Posts : 96
Join date : 2014-10-05
Age : 54
Location : Mesa, AZ

TBI rough idle and running 350. Empty
PostSubject: Re: TBI rough idle and running 350.   TBI rough idle and running 350. Icon_minitimeWed Nov 12, 2014 2:50 pm

I had a problem similar. Mine would die at an idle in gear or in park or sometimes driving down the road. I also have a '93 350/TBI crate motor. A mechanic I knew put a temporary inline fuel pressure gauge on it where we could see it when we drove around and the fuel pressure would all the sudden drop real fast to 6 psi. and die. Replaced the fuel pump and problem solved. Dropping the tank wasn't as bad as you might think. Be careful of the sending unit, they're expensive. Paul
Back to top Go down
Fred Kiehl

Fred Kiehl

Posts : 5287
Join date : 2009-11-13
Age : 70
Location : Largo, FL 33774

TBI rough idle and running 350. Empty
PostSubject: Re: TBI rough idle and running 350.   TBI rough idle and running 350. Icon_minitimeWed Nov 12, 2014 6:43 pm

You can put the metal lines from a 91-92 FW with an LO3/5 engine, or from a 93 FW. They have Schrader valve ports, and you can measure your fuel pressure. You could also check the ground at the thermostat housing. The ground is for the computer and O2 sensor. My LO3 would stall and run rough at idle until I fixed the thermostat ground. You could have a broken wire somewhere that is making physical contact most of the time.
Back to top Go down
cllong

cllong

Posts : 6
Join date : 2014-11-07

TBI rough idle and running 350. Empty
PostSubject: Re: TBI rough idle and running 350.   TBI rough idle and running 350. Icon_minitimeThu Nov 13, 2014 3:03 pm

Thanks guys. Supposedly all the recommendations you've mentioned have been checked by my local mechanic. I'm to the point of just taking it to a Buick dealership and see if their people can track it down. In addition, with the artic blast this week, the heater won't put out warm air. The fluid level is correct. I'm gonna put the 195 thermostat in this weekend. I'll be double checking the ground at the thermo also. This forum is the greatest. Thanks for letting me join. Freezing in Kentucky.
Back to top Go down
Fred Kiehl

Fred Kiehl

Posts : 5287
Join date : 2009-11-13
Age : 70
Location : Largo, FL 33774

TBI rough idle and running 350. Empty
PostSubject: Re: TBI rough idle and running 350.   TBI rough idle and running 350. Icon_minitimeThu Nov 13, 2014 7:06 pm

The 195 thermostat may be an issue if the current one is a lower temp. The car will only run correctly with the 195 thermostat.
Back to top Go down
scoffman

scoffman

Posts : 553
Join date : 2012-02-21
Age : 42
Location : Lawrenceburg, KY

TBI rough idle and running 350. Empty
PostSubject: Re: TBI rough idle and running 350.   TBI rough idle and running 350. Icon_minitimeFri Nov 14, 2014 10:23 am

You probably need to flush the heater core to get the heat to work. Also if you have a BRW, you might want to try the climate control reset in case the calibration for the blend module is out of whack.

To be honest the stalling when warm issue sounds like a heat soak issue with the coil or Distributor. The magnets in the distributor could be cracking up causing the rough idle/miss while steady cruise issue.
Then again the miss while steady cruise could also be EGR related.
Back to top Go down
cllong

cllong

Posts : 6
Join date : 2014-11-07

TBI rough idle and running 350. Empty
PostSubject: Re: TBI rough idle and running 350.   TBI rough idle and running 350. Icon_minitimeFri Nov 14, 2014 3:24 pm

Thanks again guys. Will have to check the fuel pressure, thermo ground and dist. this weekend. My mechanic may have missed some of these in his frustration. PS how do I add photos to a post?
Back to top Go down
cllong

cllong

Posts : 6
Join date : 2014-11-07

TBI rough idle and running 350. Empty
PostSubject: Re: TBI rough idle and running 350.   TBI rough idle and running 350. Icon_minitimeWed Nov 19, 2014 9:55 am

Great news. The problem was a bad wire on the ground at the thermo housing. Thanks for all your suggestions. Again, a great site.
Back to top Go down
Sponsored content




TBI rough idle and running 350. Empty
PostSubject: Re: TBI rough idle and running 350.   TBI rough idle and running 350. Icon_minitime

Back to top Go down
 
TBI rough idle and running 350.
Back to top 
Page 1 of 1

Permissions in this forum:You cannot reply to topics in this forum
GM Longroof Forum :: Longroof Tech :: Engine-
Jump to: