HomeHome  PortalPortal  CalendarCalendar  GalleryGallery  FAQFAQ  SearchSearch  RegisterRegister  Log in  

Share | 
 

 New fuel pump but no start

Go down 
AuthorMessage
Zanethan



Posts : 9
Join date : 2014-11-15

PostSubject: New fuel pump but no start   Sun Dec 06, 2015 5:31 pm

So last night the fuel pump in my roadie died as indicated by the lack of any noise coming from it when the ignition was turned on. After replacing the fuel pump if fired right up and ran for about 10 minutes. After 10 minuted it died again and refuses to start. The fuel pump is making the whiring noise so I don't think it is that. I also replaced the ignition coil and distributor cap thinking it could be those but to no avail. I also checked and cleaned the ground on the thermostat housing. The injectors fire a nice cone shaped spray but only every so often when trying to start. I am at a loss other than maybe the distributor itself. Does anyone have any other ideas?
Back to top Go down
jayoldschool

avatar

Posts : 2494
Join date : 2009-06-14

PostSubject: Re: New fuel pump but no start   Sun Dec 06, 2015 6:11 pm

Coil wire, ICM are both possibilities.
Back to top Go down
Zanethan



Posts : 9
Join date : 2014-11-15

PostSubject: Re: New fuel pump but no start   Sun Dec 06, 2015 8:59 pm

I'll look into the ICM. When the ignition is on there is a constant supply of power to the ignition coil. Would this still exist if the ICM was bad?

Also, I have already checked the fuse for the ECM and it was good.
Back to top Go down
Zanethan



Posts : 9
Join date : 2014-11-15

PostSubject: Re: New fuel pump but no start   Tue Dec 08, 2015 7:44 pm

Looks like it was the ICM. It starts right up now! Thanks!
Back to top Go down
Sponsored content




PostSubject: Re: New fuel pump but no start   

Back to top Go down
 
New fuel pump but no start
Back to top 
Page 1 of 1
 Similar topics
-
» EC receives UK application for 5p off islanders' fuel
» Free Harmony Hand Pump
» U>S> trying to start new Cold War, says Russia
» Maddie Cops To Start Digging Up Resort - Daily Mirror
» Fresh water pump issue..

Permissions in this forum:You cannot reply to topics in this forum
GM Longroof Forum :: Longroof Tech :: Engine-
Jump to: