HomeHome  PortalPortal  CalendarCalendar  GalleryGallery  FAQFAQ  SearchSearch  RegisterRegister  Log in  

Share | 
 

 Come all Ye 4l60e Guru's..strange issue

View previous topic View next topic Go down 
AuthorMessage
Bluelick



Posts : 8
Join date : 2017-07-11

PostSubject: Come all Ye 4l60e Guru's..strange issue   Tue Jul 11, 2017 4:15 pm

Hello and good day everyone.I'd like to say thank for the forum I have been a reader and searcher for some time.I come to you today with a strange issue.I need some help !

2002 Avalanche 1500 2 wd 5.3..

I'll start off by saying no codes are found or stored..Now to the Guru stuff.

The truck will not shift until it reaches right around 4,000 rpm,when it does shift it is hard as you might guess,no flashing can be detected.It is not in limp mode as it takes off in 1st gear. Here are some things I have already eliminated,,TPS,MAF,MAP,and VSS.It does have a cracked neutral safety switch that will be replaced but I don't see that causing the problem..Any help would be very helpful ! I was going to pull it and rebuild it,but I don't think the shift issue at this time is a mechanical one,or at least I don't think so.I'm leaning more like ECU or something electronic related.
I will perform any testing that is recommended and get back as soon as possible..

Thanks again in advance for any help you guru's might have...
Back to top Go down
Rev Bob



Posts : 184
Join date : 2016-05-24

PostSubject: Re: Come all Ye 4l60e Guru's..strange issue   Tue Jul 11, 2017 6:20 pm

If the driver in the PCM that controls the pressure regulating solenoid inside the transmission is flaky, you would have that symptom. All the gears are available, but when it shifts, it is a slam, because the pressure regulator fails in full pressure mode. Because this is a duty-cycle modulated output from the PCM, it does not self-check and set a code.

You might try the old battery disconnect trick to reset the PCM. Can't hurt.
Back to top Go down
jayoldschool

avatar

Posts : 2411
Join date : 2009-06-14

PostSubject: Re: Come all Ye 4l60e Guru's..strange issue   Tue Jul 11, 2017 9:05 pm

Rebuild time. Guy at work had the exact symptoms on his Avalanche two months ago. Look at the trans problems list on the SS forum (it's probably here, too), your exact issue is on there.
Back to top Go down
Bluelick



Posts : 8
Join date : 2017-07-11

PostSubject: Re: Come all Ye 4l60e Guru's..strange issue   Wed Jul 12, 2017 10:25 am

Jayoldschool,,I don't see anything related.Could you point me please?

Tks..RevBob,I will check it out.I'm thinking of having the thing hooked to a better scanner than I have and getting it diagnosed to see if it is an electronic issue..
Back to top Go down
Andebe

avatar

Posts : 2850
Join date : 2013-02-20
Age : 48
Location : Richmond,Indiana

PostSubject: Re: Come all Ye 4l60e Guru's..strange issue   Wed Jul 12, 2017 11:17 am

One of our company rides (Avalanche) had the same symptoms. After inspection it was quickly traded in. No
Back to top Go down
Bluelick



Posts : 8
Join date : 2017-07-11

PostSubject: Re: Come all Ye 4l60e Guru's..strange issue   Wed Jul 12, 2017 11:33 am

Update..we were wrong about it being in first gear,,IN this truck I don't think first gear would go to 40mph and then shift..After unplugging the electrical connector from the trans to force it in limp mode,,there is no change.So it most be in limp mode already which would be second gear...We are going to change the saftety switch since it is cracked along with splicing in new connectors,so I can be sure it isn't something as stupid as the CPU doesn't know what gear it is in...Will update in a few hours...

But I would still like a link to that post to read over...Tks
Back to top Go down
Bluelick



Posts : 8
Join date : 2017-07-11

PostSubject: Re: Come all Ye 4l60e Guru's..strange issue   Thu Jul 13, 2017 2:36 pm

Update..after replacing the safety switch and both plugs....NO Change,,,took it to a buddy and dropped it off so he can run a scan test on the ECU and if it is calling out correct commands..Will let y'all know what the outcome of that is..
Back to top Go down
Bluelick



Posts : 8
Join date : 2017-07-11

PostSubject: Re: Come all Ye 4l60e Guru's..strange issue   Thu Jul 13, 2017 5:04 pm

ECU checks out good all commands are present...Pulling it out will post what i find....
Back to top Go down
jayoldschool

avatar

Posts : 2411
Join date : 2009-06-14

PostSubject: Re: Come all Ye 4l60e Guru's..strange issue   Thu Jul 13, 2017 8:33 pm

Sounds like # 6 or # 9 from the ISSF list (and one of those was my buddy's issue)

6. No 3rd or 4th gear: “3-4” clutches are worn out. R&R. The car is safe to drive (in 2) until you can get it fixed.
7. Sudden grinding noise with no prior warning primarily in 2nd gear, behavior in reverse may be abnormal; sunshell is fractured. R&R. Try not to run or drive the car or further damage could result.
8. 1st and 3rd only, no 2,4 or R; sunshell is fractured or splines are sheared off. R&R. Try not to run or drive the car or further damage could result.
9. No 2nd or 4th gear. 2-4 band is slipping. Servo seals may be damaged (can be fixed without removing trans. Otherwise, 2-4 band is worn out. R&R.
Back to top Go down
Bluelick



Posts : 8
Join date : 2017-07-11

PostSubject: Re: Come all Ye 4l60e Guru's..strange issue   Mon Jul 17, 2017 12:59 pm

Well here we go,,3&4 clutches burnt up,so bad 3 of the clutches had no friction material left at all and had eaten into the steels.2/4 band burnt up,reverse input drum that band rides on was in such bad shape and grooved it had to be resurfaced. Also I found the servo seals damaged which could have started the damage off to begin with not sure...Rebuilt the unit and will be test driving today..Will update after test drive..Tks to all who took part in the post !
Back to top Go down
jayoldschool

avatar

Posts : 2411
Join date : 2009-06-14

PostSubject: Re: Come all Ye 4l60e Guru's..strange issue   Mon Jul 17, 2017 9:14 pm

Not one of those times I like being right. Glad you're getting it sorted out.
Back to top Go down
Bluelick



Posts : 8
Join date : 2017-07-11

PostSubject: Re: Come all Ye 4l60e Guru's..strange issue   Tue Jul 18, 2017 3:29 pm

Jerry Reed said it best many years ago bro..."When Your Hot,,,Your Hot !!" LOL

Tks again,,test drive went well,,so as my friends say's..."Ship It "
Back to top Go down
Sponsored content




PostSubject: Re: Come all Ye 4l60e Guru's..strange issue   

Back to top Go down
 
Come all Ye 4l60e Guru's..strange issue
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» Authorities Investigate Strange Slaying of Young Ohio Couple
» The “Niggle” and Strange Tale of Robert Murat - Paulo Reis
» Stepmom of Haleigh Cummings involved in strange road rage case
» Pinky is now Simon cowells PR guru?
» Hadn't seen this before.... 'Gerrys Strange Behaviour'

Permissions in this forum:You cannot reply to topics in this forum
GM Longroof Forum :: Longroof Tech :: Drivetrain and Towing-
Jump to: