HomeHome  PortalPortal  GalleryGallery  SearchSearch  RegisterRegister  Log in  

Share
 

 Help! New PS pump wont work!

Go down 
AuthorMessage
Bud89GT



Posts : 33
Join date : 2013-05-26

Help!  New PS pump wont work! Empty
PostSubject: Help! New PS pump wont work!   Help!  New PS pump wont work! Icon_minitimeFri Jul 12, 2013 4:06 pm

Symptom - after changing to new (rebuilt) pump, Had car elevated, bled out air and drove around.  Steering worked awesome for 1 mile, then went back to old ways, which is no PS at low speed/RPM.  Belt is dry.

Really need some sage advice here.  '94 RMW w/ var pwr assist (It's an NV-7)

Cheers,
Bud
Back to top Go down
Bud89GT



Posts : 33
Join date : 2013-05-26

Help!  New PS pump wont work! Empty
PostSubject: Re: Help! New PS pump wont work!   Help!  New PS pump wont work! Icon_minitimeSat Jul 13, 2013 8:19 am

ok, need to add more info. System was bled of all old fluid too. Did not change hoses except for low pressure short hose from resevior to pump.

Took car for another drive when cold. Weird, but PS worked great for a mile, again, then did its lo pressure/speed cut off again. You can feel the resistance coming on as you drive, it's not a sudden loss of steering effort.
Back to top Go down
brokecello
Moderator
brokecello

Posts : 3444
Join date : 2009-05-28
Age : 41
Location : Greenville, SC

Help!  New PS pump wont work! Empty
PostSubject: Re: Help! New PS pump wont work!   Help!  New PS pump wont work! Icon_minitimeSat Jul 13, 2013 8:25 am


Did you unplug the Var assist and see if it changed anything? (the plug on the hard line about 6in from the steering box)

Back to top Go down
http://www.ChrisPowellmusic.com
brokecello
Moderator
brokecello

Posts : 3444
Join date : 2009-05-28
Age : 41
Location : Greenville, SC

Help!  New PS pump wont work! Empty
PostSubject: Re: Help! New PS pump wont work!   Help!  New PS pump wont work! Icon_minitimeSat Jul 13, 2013 8:28 am


And are you sure nothing is leaking? (like water pump weeping out the hole?)
Back to top Go down
http://www.ChrisPowellmusic.com
Bud89GT



Posts : 33
Join date : 2013-05-26

Help!  New PS pump wont work! Empty
PostSubject: Re: Help! New PS pump wont work!   Help!  New PS pump wont work! Icon_minitimeSat Jul 13, 2013 9:14 am

brokecello wrote:

Did you unplug the Var assist and see if it changed anything?  (the plug on the hard line about 6in from the steering box)


Unplugged it, not from hard line, but rather from firewall side next to donut sensor. Maybe good idea to try that again.

Back to top Go down
Bud89GT



Posts : 33
Join date : 2013-05-26

Help!  New PS pump wont work! Empty
PostSubject: Re: Help! New PS pump wont work!   Help!  New PS pump wont work! Icon_minitimeSat Jul 13, 2013 9:19 am

brokecello wrote:

And are you sure nothing is leaking? (like water pump weeping out the hole?)

yep, belt and pullies dry as bone after drive. I checked it immediately after both runs/drives. Also, tension is good...just put new tensioner pully on prior to PS pump work.

Thanks for your replys brokecello!
Back to top Go down
Guest
Guest



Help!  New PS pump wont work! Empty
PostSubject: Re: Help! New PS pump wont work!   Help!  New PS pump wont work! Icon_minitimeSat Jul 13, 2013 9:25 am

Do you have a steering stabilizer shock on yours and if so could it be seizing up,once thoroughly warmed up?Usually becomes very hot if binding.
Back to top Go down
Bud89GT



Posts : 33
Join date : 2013-05-26

Help!  New PS pump wont work! Empty
PostSubject: Re: Help! New PS pump wont work!   Help!  New PS pump wont work! Icon_minitimeSat Jul 13, 2013 9:43 am

Flasheroo wrote:
Do you have a steering stabilizer shock on yours and if so could it be seizing up,once thoroughly warmed up?Usually becomes very hot if binding.

Jim, if you're referring to the coilover shock that attaches to the tie-rod on the undercarriage, then no, I don't have one installed.

Bud.
Back to top Go down
brokecello
Moderator
brokecello

Posts : 3444
Join date : 2009-05-28
Age : 41
Location : Greenville, SC

Help!  New PS pump wont work! Empty
PostSubject: Re: Help! New PS pump wont work!   Help!  New PS pump wont work! Icon_minitimeSat Jul 13, 2013 9:52 am

Your balancer might be slipping too. Put a paint line along the font and see if that line comes apart. Your rubber inner piece might be going.
Back to top Go down
http://www.ChrisPowellmusic.com
Bud89GT



Posts : 33
Join date : 2013-05-26

Help!  New PS pump wont work! Empty
PostSubject: Re: Help! New PS pump wont work!   Help!  New PS pump wont work! Icon_minitimeSat Jul 13, 2013 10:35 am

brokecello wrote:
Your balancer might be slipping too. Put a paint line along the font and see if that line comes apart. Your rubber inner piece might be going.

Will do.
Back to top Go down
Bud89GT



Posts : 33
Join date : 2013-05-26

Help!  New PS pump wont work! Empty
PostSubject: Re: Help! New PS pump wont work!   Help!  New PS pump wont work! Icon_minitimeSat Jul 13, 2013 3:39 pm

Ok, as far as I can tell, i fixed it. Ran it for 4th time with front end elevated to work out any more potential air in system. After 5 miles of driving and 1 hour of motor running at idle, it appears to be operational.

Thanks for all your input brokecello and Jim!

Cheers,
Bud
Back to top Go down
Guest
Guest



Help!  New PS pump wont work! Empty
PostSubject: Re: Help! New PS pump wont work!   Help!  New PS pump wont work! Icon_minitimeSat Jul 13, 2013 3:52 pm

Sounds like you figured it out on your own,hope its fixed.
Back to top Go down
brokecello
Moderator
brokecello

Posts : 3444
Join date : 2009-05-28
Age : 41
Location : Greenville, SC

Help!  New PS pump wont work! Empty
PostSubject: Re: Help! New PS pump wont work!   Help!  New PS pump wont work! Icon_minitimeSat Jul 13, 2013 10:41 pm

Good deal!! 

  Chris
Back to top Go down
http://www.ChrisPowellmusic.com
Bud89GT



Posts : 33
Join date : 2013-05-26

Help!  New PS pump wont work! Empty
PostSubject: Re: Help! New PS pump wont work!   Help!  New PS pump wont work! Icon_minitimeMon Jul 15, 2013 1:20 am

Thanks Jim and Chris...and btw, the balancer looked solid. No slipping.

Cheers,
Bud.
Back to top Go down
Sponsored content




Help!  New PS pump wont work! Empty
PostSubject: Re: Help! New PS pump wont work!   Help!  New PS pump wont work! Icon_minitime

Back to top Go down
 
Help! New PS pump wont work!
Back to top 
Page 1 of 1
 Similar topics
-
» admin password wont work anymore?
» Chatbox Won't Load
» SMS not work for Slovakia
» Links don't work on HTML page
» Illegal Sites and a Litigation panel that does not work?

Permissions in this forum:You cannot reply to topics in this forum
GM Longroof Forum :: Longroof Tech :: Engine-
Jump to: