HomeHome  PortalPortal  CalendarCalendar  GalleryGallery  FAQFAQ  SearchSearch  RegisterRegister  Log in  

Share | 
 

 Newbie to the forum!!! had my 95 RMW for 8 yrs!!

View previous topic View next topic Go down 
AuthorMessage
goodbudwrnch329

avatar

Posts : 32
Join date : 2013-07-29
Location : oak forest il.

PostSubject: Newbie to the forum!!! had my 95 RMW for 8 yrs!!   Mon Jul 29, 2013 2:00 pm

I think I got this (post correct?). well let me tell you a story about how I got my woody. first it was my brothers car. which he despises gm products especially after this car. it almost spent more time in the garage than he drove it. Then about the time I had twin boys born he decided to by a grand marquis. he loves ford products, and vw's, but that's another issue. so since I now have 3 kids he figured he would cut me a deal on the wagon. 1500 and it your to fix. needed optispark and water pump which he already bought. me being a mechanic ummm sure!!
So I tow it home, replace the parts and runs good for a couple of years. by the way, I did race his 04 merc with my 95 RMW. well to be fair he only had a 4.6 to my 5.7. end of story, I got a jump on him and kept puling away. only way he would catch me is @110 mph my ignition cuts off and he can still go. after some time thought I had to replace the optispark again. when it rained or heavy moisture in the air car would not start. changed optispark , ignition mod. and coil. again after some time wouldn't start. also quit on me on the way home from work in 14 degree weather. also changed fuel pump, filter, relay. work good for a time and crap out again. finially found I had a bad coil. I needed a second person to crank the engine while I looked under hood. saw spark glowing from top radiator hose clamp (reflection of bad coil arcing). changed coil and coil wires. no more problems. BTW, about the time my wagon was now dependable any day, any time, he 01 beetle was on the hook more often than my wagon ever was. HAHAHAHAHA. I tesed him about of course. he was always dissing the gms. that led up to 2 yrs ago. now its time to replace plugs and wires, tires, and renew the plates. over $600 woth to put into it and its rusted pretty badly. holes in the left rear wheel well where seat belt anchor is supposed to be?!?!?! cant use the belt and get a breeze in car in winter. kids don't like the back seat any more. do I fix or get rid of it??? different anwser different day. i'm not a body person to fix rust holes but had dreams of hot rodding it out with tubbed rear end. that's a lot more money. another random thought....anyone fix their suspension enough to auto cross their big wagon. something different!!!! I'll figure a way to post pic of it. thanks for reading this. might have rambled on but it was a funny story living it out.
Back to top Go down
Guest
Guest



PostSubject: Re: Newbie to the forum!!! had my 95 RMW for 8 yrs!!   Mon Jul 29, 2013 2:37 pm

Welcome to the madness,sounds like you already have plenty to talk about!lol! 
Back to top Go down
81X11

avatar

Posts : 8938
Join date : 2010-06-23
Age : 42
Location : Round Rock Texas

PostSubject: Re: Newbie to the forum!!! had my 95 RMW for 8 yrs!!   Mon Jul 29, 2013 2:38 pm

Welcome to the forum and please post pics when you can.

-Mike
Back to top Go down
goodbudwrnch329

avatar

Posts : 32
Join date : 2013-07-29
Location : oak forest il.

PostSubject: Re: Newbie to the forum!!! had my 95 RMW for 8 yrs!!   Mon Jul 29, 2013 2:43 pm

I got excited to see the custom work some people have done to their car. never new the wagons were so popular. think I need to keep mine!!
HI mike, i'm Mike also. I like the listings of your cars on your posts. I need to figure out how to do the same. I not partial to ford,gm or dodge since I have one of each. also have a 95 ram 1500 and 00 windstar
Back to top Go down
Lynol

avatar

Posts : 755
Join date : 2010-06-29
Age : 33
Location : Central New Jersey

PostSubject: Re: Newbie to the forum!!! had my 95 RMW for 8 yrs!!   Mon Jul 29, 2013 3:25 pm

Welcome to the forum. In addition to my GM's, I also own two Fords and a Dodge. They all have their own pluses and minuses. And with all of them comes a point when you're trying to fix something and you say "WHO DESIGNED THIS!!???!?!?!?" When you can you should take some pics of the rusty areas you're concerned with. I'm sure a bunch of folks would be able to give you input. I've had some rusty wagons in the past too, lol. Some not so savable.
Back to top Go down
silverfox103
Moderator
avatar

Posts : 2578
Join date : 2008-11-05
Age : 68
Location : Littleton, NH & St. Simons, GA

PostSubject: Re: Newbie to the forum!!! had my 95 RMW for 8 yrs!!   Mon Jul 29, 2013 3:33 pm

goodbudwrnch329 wrote:
I like the listings of your cars on your posts. I need to figure out how to do the same.

Mike you need to go to your profile and then signature, to add your cars.

Tom
Back to top Go down
BigBlackBeaSSt

avatar

Posts : 4495
Join date : 2009-08-01
Age : 51
Location : Lewisberry, PA

PostSubject: Re: Newbie to the forum!!! had my 95 RMW for 8 yrs!!   Mon Jul 29, 2013 4:20 pm

Several folks auto cross our cars. Most of the Impala SS components swap to ours (91-96). Rear control arms, tubular front control arms. Front sway bars, bushings, etc. (rear is wider than sedan). Talk to toomanytoyz for specifics. He is the most active poster that autocrosses.

Back to top Go down
GSBULLDOG

avatar

Posts : 313
Join date : 2010-12-24
Location : Memphis Tn

PostSubject: Re: Newbie to the forum!!! had my 95 RMW for 8 yrs!!   Mon Jul 29, 2013 5:13 pm

Welcome to the madness . These cars are fun to own & great for those of us with kids or pets . The folks on here have a wealth of info about our addiction . But anyway glad to have you with us .
Back to top Go down
goodbudwrnch329

avatar

Posts : 32
Join date : 2013-07-29
Location : oak forest il.

PostSubject: Re: Newbie to the forum!!! had my 95 RMW for 8 yrs!!   Sun Aug 11, 2013 3:50 am

well, i managed to change my avatar picture and my signature, listing my cars. still having trouble getting picture of them up on my posts. been busy last week or so. had a chance to play with it and resized picture to well within limits to gallery but wont upload. says file too large or corrupted?? any help would be appreciated. MIKE
Back to top Go down
silverfox103
Moderator
avatar

Posts : 2578
Join date : 2008-11-05
Age : 68
Location : Littleton, NH & St. Simons, GA

PostSubject: Re: Newbie to the forum!!! had my 95 RMW for 8 yrs!!   Sun Aug 11, 2013 8:56 am

goodbudwrnch329 wrote:
now its time to replace plugs and wires, tires, and renew the plates. over $600 worth to put into it and its rusted pretty badly. holes in the left rear wheel well where seat belt anchor is supposed to be?!?!?! cant use the belt and get a breeze in car in winter.
Don't know if it's a recent picture, but your car still looks pretty decent. "Plugs and wires, tires, and renew the plates" that's stuff you have to do on any car. For whatever reason they like to rust where the seatbelt connects. I think I would fix it; it is your daily driver.

Tom C.
Back to top Go down
Sprocket

avatar

Posts : 5265
Join date : 2008-11-04
Location : Palm Beach County

PostSubject: Re: Newbie to the forum!!! had my 95 RMW for 8 yrs!!   Tue Aug 13, 2013 4:44 pm

Hey there and welcome aboard.

Read this thread on how to post pics:
http://gmlongroof.4umer.com/t55-read-this-first-how-to-post-pics-now-with-pics

When I bought my 94 wagon for 1000 I had to dump 900 in it right away to get it good on the street. 95,000 miles later it has cost me an AC compressor, starter, and fuel pump. that's it and I'd drive to Cali tomorrow. She has 222K on it now.

Rust? well that's a whole different issue Sad
Back to top Go down
1993 Roady-man

avatar

Posts : 1954
Join date : 2009-05-26
Age : 50
Location : Hogansburg, Ny 13655

PostSubject: Re: Newbie to the forum!!! had my 95 RMW for 8 yrs!!   Tue Aug 13, 2013 4:48 pm

Welcome! Post often and pix are welcomed.
Back to top Go down
goodbudwrnch329

avatar

Posts : 32
Join date : 2013-07-29
Location : oak forest il.

PostSubject: Re: Newbie to the forum!!! had my 95 RMW for 8 yrs!!   Wed Aug 14, 2013 11:56 pm

ok test for picture post #1
Back to top Go down
Sponsored content




PostSubject: Re: Newbie to the forum!!! had my 95 RMW for 8 yrs!!   

Back to top Go down
 
Newbie to the forum!!! had my 95 RMW for 8 yrs!!
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» MMSA Forum Down
» New to the forum
» The Code of Conduct for the forum
» British Foreign Office:Timeline-Madeleine McCann Case (Copied From Jill Havern's Forum-Forumotion)
» Newbie

Permissions in this forum:You cannot reply to topics in this forum
GM Longroof Forum :: The Welcome Wagon :: Introductions...-
Jump to: