HomeHome  PortalPortal  CalendarCalendar  GalleryGallery  FAQFAQ  SearchSearch  RegisterRegister  Log in  

Share
 

 another oil leak question

Go down 
AuthorMessage
roadsurfer



Posts : 43
Join date : 2011-02-27

another oil leak question Empty
PostSubject: another oil leak question   another oil leak question Icon_minitimeWed Sep 11, 2013 8:03 pm

hello,

about a year ago i replaced all of the seals on the front of the engine cover and believe i did
it all properly, and used the installation tool for the water pump shaft seal. yet soon after the
repair there was still an oil leak from the front cover. today i finally decided to get in there and find it.
there was a small amount of wet oil at the base of the water pump shaft seal, so i replaced it again.
when i removed the distributor there was oil on the inside lip of that black flexible seal which
contacts the spinning shaft of the distirbutor, as well as oil pooling at the bottom of the metal
ring which the metal distributor body mates with on the engine cover.
does this mean that the distributor shaft seal is bad or is it supposed to be lubricated where
it contacts the smooth spinning shaft of the distributor? could the pooling oil have run down from
the leaking water pump seal above?

sure i could just replace it but i don't know what i would do different than last time when i thought
i followed directions closely and did it right.

thanks a lot,

anthony
gainesville, florida
Back to top Go down
Limited1

Limited1

Posts : 52
Join date : 2011-08-23
Location : NE Ohio

another oil leak question Empty
PostSubject: Re: another oil leak question   another oil leak question Icon_minitimeSun Sep 15, 2013 12:39 pm

Don't forget about the 2 o-rings that are on the male part of the Optispark that goes into the engine. I recently took mine apart and they were hard and brittle. No more major oil leak for me!
Back to top Go down
roadsurfer



Posts : 43
Join date : 2011-02-27

another oil leak question Empty
PostSubject: Re: another oil leak question   another oil leak question Icon_minitimeSun Sep 15, 2013 11:28 pm

uh-oh.

i went ahead and replaced the distibutor seal but did not replace the 2 o-rings because they were only a year
old from when i installed the distibutor a year ago & they were not flattened. i didn't know that those were oil seals. i thought that the only oil seal was the outside big one which mounts into the front engine cover. if those o-rings were the problem, then they still are. i finished the job but haven't driven it yet.

thanks for your reply.
Back to top Go down
Limited1

Limited1

Posts : 52
Join date : 2011-08-23
Location : NE Ohio

another oil leak question Empty
PostSubject: Re: another oil leak question   another oil leak question Icon_minitimeMon Sep 16, 2013 9:25 am

I am not 100% sure that those are your problem, but I do know mine were bad and the whole front of my engine was leaking oil like crazy! I ended up with oil inside of my optispark which fouled everything up.
Back to top Go down
Sponsored content




another oil leak question Empty
PostSubject: Re: another oil leak question   another oil leak question Icon_minitime

Back to top Go down
 
another oil leak question
Back to top 
Page 1 of 1
 Similar topics
-
» Default avatar question
» Theme/Background question
» [PHPBB 3.0.11] Question regarding changing a Styles Color.
» BS Callout Question
» Credits question?

Permissions in this forum:You cannot reply to topics in this forum
GM Longroof Forum :: Longroof Tech :: Engine-
Jump to: