HomeHome  PortalPortal  CalendarCalendar  GalleryGallery  FAQFAQ  SearchSearch  RegisterRegister  Log in  

Share | 
 

 93 RMW heating blows cold air. Everything else seems to work. HELP

View previous topic View next topic Go down 
AuthorMessage
Juanjo_NY



Posts : 89
Join date : 2013-09-02

PostSubject: 93 RMW heating blows cold air. Everything else seems to work. HELP   Thu Dec 05, 2013 2:39 pm

Hi,

Need help troubleshooting why I get no heat in my RMW. The controls all work fine, the fan blow fine at every speed, but I only get cold air.
I hit a deer and replaced the radiator and ac condenser along few other things. And the car dosent seems to get into running temperature. While running is only 1 line in the temp gauge, and If let it idle for long time it gets to quarter for a moment and go back down. But even when the gauge is at 1/4 still blow cold air.
I put a 180 thermostat, may that be the problem?

thanks in advance.

Juanjo
Back to top Go down
silverfox103
Moderator
avatar

Posts : 2664
Join date : 2008-11-05
Age : 68
Location : Littleton, NH & St. Simons, GA

PostSubject: Re: 93 RMW heating blows cold air. Everything else seems to work. HELP   Thu Dec 05, 2013 6:06 pm

Could be your heater core is plugged. Feel both hoses going to the heater. If they are both hot, the heater core is OK. If one of them is noticeably cooler, flush the heater core.

Tom C.
Back to top Go down
Juanjo_NY



Posts : 89
Join date : 2013-09-02

PostSubject: Re: 93 RMW heating blows cold air. Everything else seems to work. HELP   Thu Dec 05, 2013 6:22 pm

thanks,
the hose form the top-right (from inside the car prospective) of the radietor, that seems the one that gos to the heating core is just cold, every other hose of the radiator is hot, the oil and trans-cooler hoses are all hot.

So I guess is a clogged heating core. How the unclogging works?
Back to top Go down
silverfox103
Moderator
avatar

Posts : 2664
Join date : 2008-11-05
Age : 68
Location : Littleton, NH & St. Simons, GA

PostSubject: Re: 93 RMW heating blows cold air. Everything else seems to work. HELP   Thu Dec 05, 2013 6:33 pm

Going to heater core there are two hoses, basically one in and one out. If one of them is cold, your heater core is plugged. You need to break into those hoses and flush both ways. Do that and you will be nice and toasty. Usually (atleast on the LT1 cars there is a pressure reducer and a T, where you can disconnect and flush. You should be able to buy an adapter at HD or Lowe's so you can connect a hose to the heater hoses.

Tom
Back to top Go down
Sponsored content




PostSubject: Re: 93 RMW heating blows cold air. Everything else seems to work. HELP   

Back to top Go down
 
93 RMW heating blows cold air. Everything else seems to work. HELP
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» Any suggestions for a stinking head cold???!!!
» JonBenet Ramsey - cold case
» Canadian Military During the Cold War
» Gerry McCann:'Something In His Eyes Dead And Cold Like A Shark'.
» Cold Case (1957) gone hot: Maria Ridulph (7)

Permissions in this forum:You cannot reply to topics in this forum
GM Longroof Forum :: Longroof Tech :: Heating and Air Conditioning-
Jump to: