HomeHome  PortalPortal  CalendarCalendar  GalleryGallery  FAQFAQ  SearchSearch  RegisterRegister  Log in  

Share | 
 

 02 sensor questions

Go down 
AuthorMessage
Wagoninabox

avatar

Posts : 503
Join date : 2011-07-11
Location : Seattle Area

PostSubject: 02 sensor questions   Wed Sep 16, 2015 7:15 pm

Greetings-

Twice now and shortly after refueling on road trips, I get a CEL. When putting the reader on it, I get a "PO157 02 Sensor circuit low voltage bank 2 sensor 2".

Is this as straight forward as replacing the 02 sensor? (I would replace them both if one is truly out).

I ask because I vaguely remember that other things could cause this code?

Thanks for any input here.
Back to top Go down
phantom 309

avatar

Posts : 5758
Join date : 2008-12-28
Age : 108

PostSubject: Re: 02 sensor questions   Wed Sep 16, 2015 8:54 pm

hows your fuel mileage,.
Back to top Go down
Wagoninabox

avatar

Posts : 503
Join date : 2011-07-11
Location : Seattle Area

PostSubject: Re: 02 sensor questions   Wed Sep 16, 2015 11:21 pm

last 2 trips I averaged 22mpg mostly highway miles.
Back to top Go down
phantom 309

avatar

Posts : 5758
Join date : 2008-12-28
Age : 108

PostSubject: Re: 02 sensor questions   Fri Sep 18, 2015 6:47 am

Change the O2's
Back to top Go down
Wagoninabox

avatar

Posts : 503
Join date : 2011-07-11
Location : Seattle Area

PostSubject: Re: 02 sensor questions   Fri Sep 18, 2015 1:30 pm

Will do. I will report back on results.
Back to top Go down
Wagoninabox

avatar

Posts : 503
Join date : 2011-07-11
Location : Seattle Area

PostSubject: Re: 02 sensor questions   Thu May 05, 2016 9:44 pm

Okay. Replaced all 4 02 sensors. They were factory originals with 160k on them. 2 long trips after replacement, I have not thrown the code.

Differance in gas mileage? Negligible....was getting 22mpg avg (highway) and after 02 replacements has gone up to 23mpg avg. I suppose that's not bad considering in 96 they were originally rated at 25mpg highway.

Also, for those of you that plan on replacing your sensors, two pieces of advice; invest in the special thread chaser to clean up the threads after removal of the old ones and jack up the front end and do it all from underneath. Access is much better that way.
Back to top Go down
jasonlachapelle

avatar

Posts : 1138
Join date : 2011-01-24
Age : 34
Location : CFB Bagotville, QC.

PostSubject: Re: 02 sensor questions   Thu May 05, 2016 10:49 pm

Wagoninabox wrote:
2 long trips after replacement, I have not thrown the code.

Differance in gas mileage?  Negligible

makes sense. The rear O2s don't affect AFR.
Back to top Go down
Sponsored content




PostSubject: Re: 02 sensor questions   

Back to top Go down
 
02 sensor questions
Back to top 
Page 1 of 1
 Similar topics
-
» Spudgun/Madeleine McCann. Same questions, same NON answers.
» Madeleine McCann: Unanswered Questions - Telegraph
» SHIELD Frequently Asked Questions [ASK HERE]
» MCMINUTE video: Why didn't Kate McCann answer these 48 QUESTIONS? Images added
» Questions The CPS Should Ask Kate McCann - In The Dock!!

Permissions in this forum:You cannot reply to topics in this forum
GM Longroof Forum :: Longroof Tech :: Engine-
Jump to: