GM Longroof Forum
Would you like to react to this message? Create an account in a few clicks or log in to continue.



 
HomeHome  PortalPortal  GalleryGallery  SearchSearch  RegisterRegister  Log in  

 

 Crank no start

Go down 
3 posters
AuthorMessage
Sherlock128

Sherlock128

Posts : 63
Join date : 2015-12-16
Age : 31
Location : Pompano Beach FL

Crank no start Empty
PostSubject: Crank no start   Crank no start Icon_minitimeSat Feb 06, 2021 9:15 pm

I replaced my opti today on my 96 RMW with an MSD Pro Billet one. I got everything back together and I went to start it it would crank but it wouldn't start. I checked for spark and it has spark. Did I miss something? If anyone has any ideas what it could be please let me know
Back to top Go down
goldwolfnhn



Posts : 228
Join date : 2019-07-11
Location : De Pere, Wisconsin

Crank no start Empty
PostSubject: Re: Crank no start   Crank no start Icon_minitimeSat Feb 06, 2021 9:31 pm

did you double check the connection with the ICM? or check fuel pressure as usually if you have spark but no fire it's a fuel issue

Wojtek likes this post

Back to top Go down
Sherlock128

Sherlock128

Posts : 63
Join date : 2015-12-16
Age : 31
Location : Pompano Beach FL

Crank no start Empty
PostSubject: Re: Crank no start   Crank no start Icon_minitimeSat Feb 06, 2021 9:41 pm

goldwolfnhn wrote:
did you double check the connection with the ICM? or check fuel pressure as usually if you have spark but no fire it's a fuel issue

No I didn't check the ICM or the FP yet. It was running fine before I changed it well except for the miss from the old opti lol
Back to top Go down
Sherlock128

Sherlock128

Posts : 63
Join date : 2015-12-16
Age : 31
Location : Pompano Beach FL

Crank no start Empty
PostSubject: Re: Crank no start   Crank no start Icon_minitimeSun Feb 07, 2021 10:41 am

I sprayed some starting fluid in and it ignited but the engine didn't start. Could I have installed the opti wrong? And the timing is off?
Back to top Go down
goldwolfnhn



Posts : 228
Join date : 2019-07-11
Location : De Pere, Wisconsin

Crank no start Empty
PostSubject: Re: Crank no start   Crank no start Icon_minitimeSun Feb 07, 2021 11:35 am

you should have the pin drive so it should only go on one way, I would check the fuel pressure first before tearing apart the front of the engine again, especially when starting fluid got a reaction, to me that makes it sound like either the injectors aren't working for some reason or there's no fuel getting to them.

I think with the multi port system the ICM controls which injectors fire, so if the connection for the ICM is not good enough the pcm doesn't know when to set off the injectors to put fuel in the cylinders. But I might be wrong.
Back to top Go down
Sherlock128

Sherlock128

Posts : 63
Join date : 2015-12-16
Age : 31
Location : Pompano Beach FL

Crank no start Empty
PostSubject: Re: Crank no start   Crank no start Icon_minitimeSun Feb 07, 2021 12:54 pm

Yeah it has the pin drive I remember seeing on the back of the opti, it had the 3 holes for the bolt heads and 3 smaller holes for the pin drive 2 of the pin holes were circles and 1 of them was elongated does it matter which hole the pin goes in or does it have to go in that elongated one?
Back to top Go down
goldwolfnhn



Posts : 228
Join date : 2019-07-11
Location : De Pere, Wisconsin

Crank no start Empty
PostSubject: Re: Crank no start   Crank no start Icon_minitimeSun Feb 07, 2021 2:40 pm

I've never replaced an opti yet, just the cap and rotor, so not sure, maybe someone else here knows.

But I once replaced the timing belt on my moms escort and got the timing off, but the engine would still cough and sputter trying to start. that's why I commented about checking the fuel or the ICM connections first as it seems to me that there might be a fuel issue rather then timing.
Back to top Go down
Sherlock128

Sherlock128

Posts : 63
Join date : 2015-12-16
Age : 31
Location : Pompano Beach FL

Crank no start Empty
PostSubject: Re: Crank no start   Crank no start Icon_minitimeFri Feb 19, 2021 6:00 pm

Well I was able to get it started and running idk what I did but whatever I did worked lol I put the old opti back on and got it to start so I put the new opti back on and it started up the only thing I can think of is that the pin wasn't in the right hole
Back to top Go down
rcktpwrd

rcktpwrd

Posts : 358
Join date : 2019-03-06
Age : 47
Location : Raleigh, NC

Crank no start Empty
PostSubject: Re: Crank no start   Crank no start Icon_minitimeSat Feb 20, 2021 5:41 pm

Good to hear you got it sorted out.
I would guess you just didn't have it lined up properly the first time.
Back to top Go down
Sponsored content




Crank no start Empty
PostSubject: Re: Crank no start   Crank no start Icon_minitime

Back to top Go down
 
Crank no start
Back to top 
Page 1 of 1

Permissions in this forum:You cannot reply to topics in this forum
GM Longroof Forum :: Longroof Tech :: Engine-
Jump to: