HomeHome  PortalPortal  GalleryGallery  SearchSearch  RegisterRegister  Log in  

Share
 

 Bad TPS? IAC? or Opti?

Go down 
AuthorMessage
1lowcaprice

1lowcaprice

Posts : 32
Join date : 2013-02-03
Age : 34
Location : NW Indiana

Bad TPS? IAC? or Opti? Empty
PostSubject: Bad TPS? IAC? or Opti?   Bad TPS? IAC? or Opti? Icon_minitimeFri Jul 10, 2015 2:49 pm

Car is a 94 roadie wagon. Out of seemingly nowhere the car won't start, fresh tune up (not the opti) and new ignition coil. Also the ICM checked out good. If I pump the gas and hold it down it will start run bad for a sec then Idle straight. Go to rev it up and there's a hiccup before it catches up. Fuel filter was new last year same with fuel pump. Fuel pressure is right around 40. Opti is pretty expensive so hoping to make sure its positively that before I do it. I was thinking (hoping) maybe the TPS or IAC could be bad? Anyway to test these? Thanks in advance for any help.
Back to top Go down
1lowcaprice

1lowcaprice

Posts : 32
Join date : 2013-02-03
Age : 34
Location : NW Indiana

Bad TPS? IAC? or Opti? Empty
PostSubject: Re: Bad TPS? IAC? or Opti?   Bad TPS? IAC? or Opti? Icon_minitimeFri Jul 10, 2015 2:51 pm

Even after I let it warm, up then turn it off, I have to hold down the gas almost all the way to get it to start back up.
Back to top Go down
1lowcaprice

1lowcaprice

Posts : 32
Join date : 2013-02-03
Age : 34
Location : NW Indiana

Bad TPS? IAC? or Opti? Empty
PostSubject: Re: Bad TPS? IAC? or Opti?   Bad TPS? IAC? or Opti? Icon_minitimeFri Jul 10, 2015 6:45 pm

Bit the bullet and bought the $25 TPS and a Temp Control Sensor on and problem solved.
Back to top Go down
Sponsored content




Bad TPS? IAC? or Opti? Empty
PostSubject: Re: Bad TPS? IAC? or Opti?   Bad TPS? IAC? or Opti? Icon_minitime

Back to top Go down
 
Bad TPS? IAC? or Opti?
Back to top 
Page 1 of 1

Permissions in this forum:You cannot reply to topics in this forum
GM Longroof Forum :: Longroof Tech :: Engine-
Jump to: